Gqrx SDR on Ubuntu

As a first remove the installed (old) versions :

sudo apt-get purge --auto-remove gqrx
sudo apt-get purge --auto-remove gqrx-sdr
sudo apt-get purge --auto-remove libgnuradio*

After this you need to add the new repository to download 

sudo add-apt-repository -y ppa:bladerf/bladerf
sudo add-apt-repository -y ppa:ettusresearch/uhd
sudo add-apt-repository -y ppa:myriadrf/drivers
sudo add-apt-repository -y ppa:myriadrf/gnuradio
sudo add-apt-repository -y ppa:gqrx/gqrx-sdr
sudo apt-get update

than install the packages

sudo apt-get install gqrx-sdr

in my opinion it is recommended,
that you optimize your machine before 
the first start of the program

sudo apt-get install libvolk1-bin
volk_profile

done
Advertisements